AMH开源社区

AMH社区 - 开放自由有价值的社区

[综合话题] php 7.1、7.2环境安装不了swoole

断了线
铁牌会员
105.55 价值分

129 次阅读   3 张回复   断了线 发表于 2021-04-01 17:50:23
Configuring for:
PHP Api Version: 20170718
Zend Module Api No: 20170718
Zend Extension Api No: 320170718
config.m4:311: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
config.m4:311: the top level
autom4te: /usr/bin/m4 failed with exit status: 63
/root/amh/modules/swoole-4.6/admin-script/install_swoole: line 22: ./configure: No such file or directory
make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target `install'. Stop.
mv: cannot stat `/usr/local/php-7.2/lib/php/extensions/no-debug-non-zts-20170718/swoole.so': No such file or directory
---------------------------
上面是错误提示
评价: 这个话题有价值吗?  没有 (0分)   有, 感谢 (0分)
2021-04-01 17:50:23 1

amysql
创始人
98763.20 价值分

error: Autoconf version 2.64 or higher is required
autoconf达不到要求,autoconf版本需要2.64以上,

rpm -qa | grep autoconf
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-01 18:04:30 2

AMH面板 - 好用高效低占用、安全可靠极稳定

断了线
铁牌会员
105.55 价值分

引用:
amysql 发表于 2021-04-01 18:04:30
error: Autoconf version 2.64 or higher is required
autoconf达不到要求,autoconf版本需要2.64以上,
rpm -qa | grep...

老大,我卸载autoconf然后安装最新版,但安装好像路径错了,/usr/bin/autoconf -V 这个命令查得到,rpm -qa | grep autoconf这个查不到了,怎么办,有没有影响
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-01 18:28:15 3

amysql
创始人
98763.20 价值分

如果你是通过rpm卸载掉的,正常rpm -qa | grep autoconf就查不到了。
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-01 18:32:29 4
 1  (总1页)
AMH社区列表

旅客

   上传附件    网址链接    隐密内容    表情
选择文件 支持格式:zip、gif、jpg、jpeg、png   (大小<10MB)
回复帖子 (+2 价值分) 您的帖子可获得其它会员的匿名评价
评为有价值时加分,没有价值即减分。 (不设上限,评价分数取决于评价人的自身价值总分)
用户服务中心