AMH开源社区

AMH社区 - 开放自由有价值的社区

[综合话题] swoole怎么安装4.5.11?最新4.6部署有问题

yexiaohai
铁牌会员
64.00 价值分

94 次阅读   6 张回复   yexiaohai 发表于 2021-04-26 21:04:41
版本怎么换成4:。5.11?
评价: 这个话题有价值吗?  没有 (0分)   有, 感谢 (0分)
2021-04-26 21:04:41 1

amh忠实拥护者,amh稳定高效!
wget http://amh.sh/amh.sh && bash amh.sh acc 13238

amysql
创始人
98763.20 价值分

4.6部署具体什么问题?
swoole4.6版本是不支持php7.1或以下的版本。

要4.5版本,可以用php7.1的环境。
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-27 11:32:05 2

AMH面板 - 好用高效低占用、安全可靠极稳定

aduydgd
铁牌会员
117.22 价值分

评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-28 08:45:44 3

AMH铁粉,诸多面板转移过来的!

yexiaohai
铁牌会员
64.00 价值分

引用:
aduydgd 发表于 2021-04-28 08:45:44
请参考:
http://amh.sh/bbs/post-10951-1-1.htm

非常感谢,同时官方给出的方案大家也可以试下:在ssh执行更改,
sed -i 's/7\.1/7\.4/' /root/amh/modules/swoole-4.6/admin-script/install_swoole

在lnmp『扩展安装』里给环境安装上swoole。
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-28 10:00:06 4

amysql
创始人
98763.20 价值分

引用:
yexiaohai 发表于 2021-04-28 10:00:06
非常感谢,同时官方给出的方案大家也可以试下:在ssh执行更改,
sed -i 's/7\.1/7\.4/' /root/amh/modules/swoole-4.6/admin-script/ins...

php7.1默认安装的4.5版本。这是更改php7.4用了swoole4.5版本。
有特别需要才这么操作。
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-28 11:34:37 5

yexiaohai
铁牌会员
64.00 价值分

明白了,3楼方案是否可行?
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-28 12:25:01 6

amysql
创始人
98763.20 价值分

如果有现成的so扩展文件的话可以参考3楼。
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-04-29 09:53:34 7
 1  (总1页)
AMH社区列表

旅客

   上传附件    网址链接    隐密内容    表情
选择文件 支持格式:zip、gif、jpg、jpeg、png   (大小<10MB)
回复帖子 (+2 价值分) 您的帖子可获得其它会员的匿名评价
评为有价值时加分,没有价值即减分。 (不设上限,评价分数取决于评价人的自身价值总分)
用户服务中心