AMH开源社区

AMH社区 - 开放自由有价值的社区

[综合话题] 安装面板的时候出现 libiconv-1.14 is not installed.

winwtf2012
铁牌会员
8.00 价值分

77 次阅读   4 张回复   winwtf2012 发表于 2021-05-02 06:27:18
你好,安装面板的时候出现这个安装不到了,已经重新安装centos7和8都是安装到这里出问题,请问怎么解决。谢谢


libiconv-1.14/build-aux/install-sh
libiconv-1.14/build-aux/snippet/
libiconv-1.14/build-aux/snippet/_Noreturn.h
libiconv-1.14/build-aux/snippet/warn-on-use.h
libiconv-1.14/build-aux/snippet/arg-nonnull.h
libiconv-1.14/build-aux/snippet/c++defs.h
libiconv-1.14/build-aux/missing
libiconv-1.14/build-aux/config.libpath
libiconv-1.14/build-aux/config.rpath
libiconv-1.14/build-aux/ltmain.sh
libiconv-1.14/build-aux/config.sub
libiconv-1.14/.gitattributes
libiconv-1.14/m4/
libiconv-1.14/m4/ln.m4
libiconv-1.14/m4/lt~obsolete.m4
libiconv-1.14/m4/libtool.m4
libiconv-1.14/m4/ltoptions.m4
libiconv-1.14/m4/proto.m4
libiconv-1.14/m4/endian.m4
libiconv-1.14/m4/cp.m4
libiconv-1.14/m4/ltversion.m4
libiconv-1.14/m4/general.m4
libiconv-1.14/m4/fcntl-o.m4
libiconv-1.14/m4/eilseq.m4
libiconv-1.14/m4/ltsugar.m4
/root/amh/modules/libiconv-1.14/AMHScript: line 26: ./configure: Permission denied
make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target `install'. Stop.
[Notice] libiconv-1.14 is not installed.
==========================================================================
Sorry, Failed to install AMH
Please contact us: http://amh.sh
评价: 这个话题有价值吗?  没有 (0分)   有, 感谢 (0分)
2021-05-02 06:27:18 1

蓝浩
铝牌会员
495.94 价值分

我们在Linux 安装包的时候,使用make 命令出现:"make:*** No targets specified and no makefile found.Stop."这样的错误提示。

我们有三种方式可以尝试解决:

第一种:

第一、update最新版本系统软件

yum update

这个必须要执行后才可以安装我们的系统软件或者一键包。

第二、编译缺失关联软件

yum install gcc build-essential

编译执行完毕之后,我们在执行./configure && make这类的执行命令就可以解决问题。
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-05-02 11:04:34 2

此用户很懒,未设置签名档!

winwtf2012
铁牌会员
8.00 价值分

他都显示这样说已经是最后版本了,其实我对linux只是个菜鸟,有一些教学的网页关于这问题吗?谢谢
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-05-02 20:17:05 3

winwtf2012
铁牌会员
8.00 价值分

Package gcc-4.8.5-44.el7.x86_64 already installed and latest version
No package build-essential available.
Nothing to do

No packages marked for update
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-05-02 20:21:08 4

amysql
创始人
98763.20 价值分

报错Permission denied是没权限的问题。
你在在ssh手动安装过什么安全软件限制了权限,要开启。
评价: 这个回复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2021-05-04 09:42:12 5

AMH面板 - 好用高效低占用、安全可靠极稳定

 1  (总1页)
AMH社区列表

旅客

   上传附件    网址链接    隐密内容    表情
选择文件 支持格式:zip、gif、jpg、jpeg、png   (大小<10MB)
回复帖子 (+2 价值分) 您的帖子可获得其它会员的匿名评价
评为有价值时加分,没有价值即减分。 (不设上限,评价分数取决于评价人的自身价值总分)
用户服务中心