AMH开源社区

AMH社区 - 开放自由有价值的社区

[求助帖] amh不支持部署laravel框架么

sf272021899
铁牌会员
83.00 价值分

6,325 次阅读   3 张回复   sf272021899 发表于 2015-03-23 21:48:02
本帖最后由 sf272021899 于 2015-4-13 21:52 编辑

laravel5是现在php最流行的框架。
开始是使用hhvm来部署 laravel5的。整完后能看到框架运行了。
但是数据库连不上 发现不支持pdo mysqli
后来换 lnmp php 5.5 5.6也不行

过程是这样的
1.新建LNMP环境 安装常用组件 opcache-1.0 mcrypt-1.0 mysqli-1.0 pdo_mysql-1.0
2.PHP临时添加到PATH
export PATH=$PATH:/usr/local/php-5.5.13/bin
3.安装PHP依赖管理工具composer
curl -sS https://getcomposer.org/installer | php
4.为了方便添加到PATH
mv composer.phar /usr/local/bin/composer


新增虚拟主机 在网站根目录下执行
composer create-project laravel/laravel --prefer-dist提示一下错误
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for laravel/framework v5.0.16 -> satisfiable by laravel/framework[v5.0.16].
- laravel/framework v5.0.16 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.

我以为我的mcrypt 没有安装。我在网站下面运行phpinfo();看到mcrypt 是已经安装的。
试了很多次都没有成功不知道哪里出了问题。系统是linode ubuntu 14.04 lts
评价: 这个问题有价值吗?  没有 (0分)   有, 感谢 (1分)
2015-03-23 21:48:02 1

amysql
创始人
97574.38 价值分

尝试把环境的amh-php.ini复制到你当使用的php软件的etc目录下
cp /home/wwwroot/环境/etc/amh-php.ini /usr/local/php-版本/etc/php.ini
评价: 这个答复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2015-03-24 13:09:44 2

sf272021899
铁牌会员
83.00 价值分

从新装回amh用管理说的方法试了一下。成功了。
评价: 这个答复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2015-04-13 22:09:26 3

baitongda
铁牌会员
198.00 价值分


Warning: The lock file is not up to date with the latest changes in composer.json. Yo may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for intervention/image 2.2.0 -> satisfiable by interventio/image[2.2.0].
- intervention/image 2.2.0 requires ext-fileinfo * -> the requested PHP extensionfileinfo is missing from your system.
评价: 这个答复有价值吗?  没有 (0分)   有, 感谢 (0分)
回复  2015-07-16 10:32:25 4
 1  (总1页)
AMH社区列表
旅客不可参与帖子, 请您先登录
用户服务中心